Binance Exchange

Excel: Totali di categoria con le formule SOMMA.SE e SOMMA.PIU.SE

Quando abbiamo una serie di voci che dobbiamo aggregare a seconda della categoria di appartenenza, possiamo utilizzare la formula SOMMA.SE
Nell’esempio seguente supponiamo di avere l’elenco degli stipendi dei dipendenti con il loro dipartimento di appartenenza e di voler calcolare la somma totale per ciascun dipartimento:

Excel somma.se example

Per farlo utilizziamo, come detto, la formula SOMMA.SE che prevede due diverse modalità di utilizzo:

– Somma degli elementi di un range con criterio di filtraggio applicato sugli elementi stessi
– Somma degli elementi di un range con criterio di filtraggio applicato ad un altro range di elementi

Vediamo prima un esempio del primo caso, il più semplice.
Utilizziamo la formula SOMMA.SE per calcolare il totale dei soli stipendi superiori a 30.000 Euro:

=SOMMA.SE(C2:C12;”>30000″)

Excel SOMMA.SE example
In questo caso infatti abbiamo applicato il filtro “>30000” direttamente sul range degli elementi da sommare.

Ora torniamo al nostro esempio, che prevede l’utilizzo della seconda modalità di SOMMA.SE con il filtraggio dei dati effettuato su un range diverso da quello dei dati da sommare. Come detto in apertura l’obbiettivo è quello di sommare gli stipendi per dipartimento e ottenere quindi un totale di categoria.

Lo facciamo con la formula: =SOMMA.SE(B2:B12;”=Vendite”;C2:C12)

Excel SOMMA.SE example

In questo caso abbiamo quindi applicato il filtraggio “=Vendite” sul range B2:B12 che è diverso dal range C2:C12 contenente gli elementi da sommare.

Questa soluzione ci va bene qualora avessimo una sola condizione in base alla quale discriminare quali valori considerare o meno. Ma se avessimo invece una serie di condizioni da soddisfare per poter sommare i nostri valori?
Aggiungiamo al nostro esempio un’ulteriore colonna “Attivo” che rappresenta un flag che indica se i dipendenti elencati sono ancora presenti in azienda o meno.

Excel SOMMA.PIU.SE example

Nel calcolo della somma degli stipendi dei vari dipartimenti dobbiamo quindi ovviamente prendere in considerazione solo quelli ancora attivi. La nostra formula dovrà quindi effettuare, per ciascuna riga, una doppio filtro: uno sul dipartimento di appartenenza del dipendente e l’altro sul valore della colonna attivo.

Per farlo utilizziamo la formula SOMMA.PIU.SE che ci permette di indicare una serie di criteri di filtraggio. La sintassi di tale formula prevede la definizione del range di valori da sommare e di una serie di coppie intervallo di filtraggio/criterio di filtraggio:

SOMMA.SE(int_somma; intervallo_criteri1; criteri1; [intervallo_criteri2; criteri2]; …)

Per la soluzione al nostro esempio la utilizziamo nel modo seguente:
=SOMMA.PIU.SE(C2:C12;B2:B12;”=Amministrazione”;D2:D12;”=SI”)

Excel SOMMA.PIU.SE example
In questo modo abbiamo indicato alla formula di sommare gli elementi del range C2:C12 in base ad un primo filtro “=Amministrazione” sul range B2:B12 ed ad un secondo filtro “=SI” applicato al range D2:D12

Leave a Reply

Your email address will not be published. Required fields are marked *